投稿した記事が表示されない



  • 当方初心者です。
    ブログ記事を初めて投稿しました。
    しかしアイコンをクリックしても記事が出てきません。
    不具合部分の切り分けができないのでお手数ですが対処方法を教えてください。
    ・固定ページの表示は問題なかった。
    ・投稿のアイキャッチ画像は問題なかった
    ・アイキャッチをクリックしても記事内容が表示されなかった。
     (アイキャッチの画像がそのままの状態)
    ・スマホでも確認したが同様の結果だった。
    ・投稿の編集は問題なく行えた
    以上、よろしくお願いします。


    マニュアル確認済み
    キャッシュクリア済み
    プラグイン全停止済み
    WordPressのバージョン : 5.8.1
    ご利用のサーバー名 : conoha
    PHPのバージョン : 7.4
    OS : win10
    ご利用のブラウザ : chrome
    該当サイトのURL : https://aiel-wings.com/



  • @aielwings さん

    こんにちは!

    検証の情報、ありがとうございます!とても助かります。

    サイトを拝見しますと記事のカードのURLが、記事のものとは違う気がしますね。。

    確認していただきたいのですが、管理画面「投稿」>「投稿一覧」に並んでいる
    Hello world! の記事のスラッグ欄は何て書いてありますか??

    0_1632632989969_スクリーンショット 2021-09-26 14.05.02.jpg

    0_1632633018908_スクリーンショット 2021-09-26 14.08.35.jpg

    ================================================
    併せて、管理画面「設定」>「パーマリンク 」の「共通設定」は
    どれが選択されているかもお知らせいただけますと幸いです。

    お手数おかけしますが、よろしくお願いいたします。



  • 回答ありがとうございます。
    投稿の方はタイトル、スラッグともに写真と同じでした。
    パーマリンクはカスタム構造で/%category%/のみを選択しています。
    オプションは空白のままです。
    お手数ですがよろしくお願いします。
    0_1632634576313_問題指摘1.png
    0_1632634587927_問題指摘2.png



  • @aielwings さん

    ご確認と画像の添付、ありがとうございます!

    あ、カスタム構造の記述が問題かもしれませんね。

    https://affilabo.com/wordpress/21658/

    ↑ こちらの記事を見ていただくと分かりやすいと思いますが、
    aielwings さんが設定したい形は、「/カテゴリー名/投稿名/」ではないですか??

    postname も入れてあげれば解決すると思います。
    お手数おかけしますが、よろしくお願いいたします!



  • Tsuno_さん
    ご指摘の通りパーマリンクの設定を下記のようにしたら表示できるようになりました。
    こんなルールがあるのを知りませんでした。
    ありがとうございました。おかげで助かりました。
    0_1632737963385_問題指摘3.png



  • @aielwings さん

    あ、直って良かったです!

    パーマリンクの設定に関しましては、サイトの運用途中で変更しない方が良いので、
    以降は基本的に変更しない方が良いと思います。

    よろしくお願いいたします。
    (ご確認いただければ、ご返信は無用ですので!)


 

});