RTOCで目次が自動表示されない



  • RTOCをインストールしましたが、目次が自動表示されません。
    投稿内にショートコードを挿入すれば、問題なく表示されます。
    キャッシュ関連(ブラウザ、サーバー、プラグイン)も確認済みなのですが。
    とりあえず現状はこれまで利用していたTOC+に戻している状態で、RTOCを是非利用したいと思っているのですが。
    何か見落としている設定や原因はありそうでしょうか?


    マニュアル確認済み
    キャッシュクリア済み
    WordPressのバージョン : 5.3.2
    ご利用のサーバー名 : x-server
    PHPのバージョン : 7.2.27
    OS : Windows10
    ご利用のブラウザ : chrome
    該当サイトのURL : https://ooimachi.info/


  • administrators

    @warakado さん

    こんにちは!JIN運営チームのりょうたです。
    この度はRTOCをご利用いただき誠にありがとうございます。

    表題の件ですが、「表示条件」や「目次を表示させるページ」にチェックが入っていますでしょうか?
    プラグインないに「ヘルプ」があったりするのでそちらを確認していただき表示されるか確認してください!

    0_1583728763458_スクリーンショット 2020-03-09 13.37.55.png

    お手数お掛け致しますが、宜しくお願い致します。



  • 返信ありがとうございます!
    実はヘルプも確認して、いろいろ試してみたのですが、上手くいかず。
    現在の基本設定のキャプチャも共有します。
    0_1583769759727_基本設定キャプチャ.png
    現在、TOC+を無効にして、RTOCを有効にしてあります。
    0_1583769883175_プラグインキャプチャ.png


  • administrators

    @warakado さん

    こんにちは!りょうたです。
    ご確認いただいていたんですね!!
    ありがとうございます。

    僕の方では再現できなかったので何かしらのプラグインが干渉している可能性もあります。
    ただ、サイトを見る限りRTOCは読み込まれているので一度RTOC以外のプラグインを停止するとどうでしょうか?

    お手数お掛け致しますが、ご確認の程宜しくお願い致します。



  • RTOC以外のプラグイン停止してみましたが、やはりダメでした。
    1_1583822841400_プラグイン停止②.png 0_1583822841398_プラグイン停止① .png
    JINで他にカスタマイズしている箇所があるとすれば、追加CSSの部分
    0_1583822900125_追加CSS.png
    だけだと思うのですが、こちら影響ありそうでしょうか?
    (試しに追加CSS削除しても目次表示されません。。。)
    お手数お掛け致しますが、ご確認の程、宜しくお願い致します。



  • こんにちは!

    プラグインの停止後の確認ありがとうございます。
    追加CSSについては影響はなさそうです。

    現在原因を探っているのですが、再現性がなく原因がわからない状態でして。。。
    一度RTOCの設定で「目次を表示させるページ」のチェックを外して保存し、その後再度チェックをいれて保存を試していただけますでしょうか?



  • @赤石
    いろいろ調べて頂いてありがとうございます!
    >一度RTOCの設定で「目次を表示させるページ」のチェックを外して保存し、その後再度チェックをいれて保存

    まず、こちらを試したところ、チェックを2つとも外して保存しても、チェックが外れずにチェックされた状態のままでチェックを外すことが出来ません。
    正確には、チェックを2つとも外して保存のみが出来ず、どちらか片方のチェックを外す、もしくは、2つともチェックをしている状態であれば、きちんと保存できます。

    しかし、その後、投稿の編集画面からプレビューを見るとプレビューにのみ目次がきちんと表示されていました。
    その際に編集画面に特に編集していないのに「以下のバージョンよりも新しい自動保存された投稿があります。自動保存を表示」(下記画像)
    0_1584026383065_編集画面を表示.png
    が表示されていたので、試しに投稿を更新したところ、目次がプレビューだけでなくサイト上にも表示されました!

    その後、プラグインの影響を調べようと思い、プラグインを1つづつ有効にする作業していたのですが、どうも
    1.プラグインの「Classic Editor」を無効にする
    2.投稿を更新する
    3.更新した投稿にのみ目次が表示される。
    4.再びClassic Editorを有効にすると目次が消える
    5.投稿を再度更新すると目次が表示される。
    という挙動が起きました。

    気になるのは、このClassic Editorを有効化や無効化した際に
    WEB上はテキストが表示されていますが、どうも裏側のソース(表現違うかもしれませんが?)
    がクリアされてしまっているような投稿のリビジョンが残っています。
    Classic Editorを無効にした際に投稿の編集画面を見ると、何も変更していないにも関わらず
    「以下のバージョンよりも新しい自動保存された投稿があります。自動保存を表示」が出てくるので
    「自動保存」の部分ををクリックすると下記画像が表示されます。
    0_1584026427391_自動保存比較.png
    もしかしたら、Classic Editorを有効化や無効化した際に、「H3」などのフラグが投稿に対して設定されていない状態になっているのかもしれません。

    一応、目次の表示有無の現象をみて頂けるように下記2つのページを見て頂けますでしょうか?
    Classic Editorを無効にした後に投稿を更新したページ
    https://ooimachi.info/sparklingwater-comparison
    Classic Editorを無効にした後に投稿を更新していないページ
    https://ooimachi.info/challenge-touch
    です。
    ちなみにClassic Editor以外のプラグインは全て有効(Table of Contents Plusは無効)にしてあります。
    以前にショートコードを直接挿入した際に目次が表示されたのは、ショートコード挿入したことで投稿が更新されたからかもしれません。


  • administrators

    @warakado さん

    こんにちは!りょうたです!!
    僕の方でも同様の流れで確認してみたところ@warakado さんと全く同じ挙動を確認することができました。
    リビジョンも全く同じようになったのでClassicEditorとGutenbergでの挙動が違うのがはっきり確認できました。

    どう対応するか一度こちらで検討させていただけますと幸いでございます!!
    ClassicEditorとGutenbergの挙動の仕方が全く違うので少し時間がかかるかと思いますが今しばらくお待ちいただけますと幸いでございます。

    早急な解決とはならず大変恐縮ではございますが、何卒ご理解の程宜しくお願い致します。



  • @ryota様
    承知しました!原因判明して良かったです!
    どうなるにせよ時間がかかるとのことですので、質問自体は一旦「解決済み」にステータス変更した方がよろしいですか?


  • administrators

    @warakado さん

    こんにちは!
    ありがとうございます。

    そうですね。。「解決済み」に一旦していただけますと幸いでございます。
    お手数お掛け致しますが、宜しくお願い致します。



  • @ryota
    承知しました。
    今後とも宜しくお願いします!