サイドバーにプロフィールが表示されない



  • 初めて投稿いたします。
    去年の10月から使用させていただいています。ブログ立ち上げ時に、サイドバーにプロフィールを入れていたのが、最近消えていることに気が付きました。
    JINのウィジェットから再設定をし、その時はプロフィール画像もコメントもきちんと入っているのですが、0_1582522433059_設定画面.JPG
    公開させるとすべて消えてしまいます。何度もやってみましたが、公開ページには表示されません。
    Wordpressのウィジェットから設定しても画像とコメントは白くなり、別の記事にリンクされてしまいます。
    キャッシュもすべてクリアしたり、他の方の投稿を見て色々やってみましたが、今だ表示されず、途方にくれています。
    どうかプロフィールが再表示されるよう、ご教示お願い致します。


    マニュアル確認済み
    キャッシュクリア済み
    プラグイン全停止済み
    WordPressのバージョン : 5.3.2
    ご利用のサーバー名 : エックスサーバー
    PHPのバージョン :
    OS :
    ご利用のブラウザ : IE,Google Chrome
    該当サイトのURL : https//hiikosolotabi.com


  • administrators

    @ヒーコ さん

    こんにちは!JIN運営チームのりょうたです。
    この度はJINご利用いただき誠にありがとうございます。

    表題の件ですが、WordPressの管理画面からウィジェットに入っていただき「使用停止中のサイドバー」にプロフィールの項目が入っていたりしませんか?
    もしあった場合はそれをウィジェットエリアに戻して再度確認してみてください。

    お手数お掛け致しますが、宜しくお願い致します。



  • @ryota さん

    ご返信ありがとうございます。
    WordPressの管理画面からウィジェットに入って確認しましたが、「利用できるウィジェット」に、プロフィールは入っています。
    「使用停止中のサイドバー」にはないです。

    よろしくお願いいたします。


  • administrators

    @ヒーコ さん

    こんにちは!りょうたです。
    ご連絡遅くなり申し訳ございません。

    なるほど。。XserverのWAFの設定がオンになっていませんででしょうか?
    もしくはプラグインなどでWAFをチューニングしていることもありませんでしょうか?

    一度上記を確認していただき、それでも解消しない場合はプロフィールを1から作成し直していただき問題が解消するかご確認いただけますと幸いでございます。
    お手数お掛け致しますが、宜しくお願い致します。



  • @ryota
    こちらこそ返信が遅くなり申し訳ありません。
    XserverのWAFの設定がオンになっていませんででしょうか? → すべての項目がOFFでした
    プラグインなどでWAFをチューニングしていることもありませんでしょうか? → プラグイン確認しましたが、ありません。

    再度作り直しましたがやはり表示されません。
    最初にお知らせしたように、設定した時は表示されるのに、公開させると消えてしまいます。

    ちなみにWordpressのウィジェットから設定しても画像とコメントは白くなり、別の記事
    https://hiikosolotabi.com/2020/02/08/hotelkasugai1/)にリンクされてしまいます。
    見ていただけるようにそのままの状態にしていますので、確認いただけると幸いです。

    お手数をおかけしますが、引き続きよろしくお願いいたします。

    0_1583411453026_キャプチャ.JPG



  • 横槍すみません。
    私もプロフィールが表示されません。
    上記同じような設定で、設定後すぐに消えてしまう現象、サイト状での見た目も全く同じです。



  • @ryota お世話になっております。
    こちら解決策はありませんでしょうか?


  • administrators

    @ヒーコ さん

    こんにちは!りょうたです。
    ご連絡遅くなり申し訳ございません。

    うーん、となるとPHPのバージョンでしょうか...。。
    サーバーのバージョンが7以上かどうか確認していただけますと幸いでございます。

    ちなみにWordpressのウィジェットから設定しても画像とコメントは白くなり、別の記事
    https://hiikosolotabi.com/2020/02/08/hotelkasugai1/)にリンクされてしまいます。
    見ていただけるようにそのままの状態にしていますので、確認いただけると幸いです。

    こちらに関してですが、プロフィールへは「https://hiikosolotabi.com/profile」のようにスラッグを「profile」にしないと飛ばないようになっているのでリンク設定を変更していただきご確認いただけますと幸いでございます。

    なんどもお手数ではございますが、何卒ご確認の程宜しくお願い致します。



  • @ryota バージョンはPHP7.3.14と最新です。

    そしてわかったことがあります。
    プロフィール名、肩書、画像、SNSボタンを設定するまでは、サイトに表示がされました。
    しかし説明に1文字でも何か書いたところ、入力していたものがすべて削除され、真っ白に戻ってしまうことが判明しました。(更新や公開を押したあとすぐに)

    ご確認のほどよろしくお願いいたします。



  • @ryota さま
    ご返信ありがとうございます。
    PHPのバージョンは、PHP7.2.27となっています。

    私もjaaさんと同じく、プロフィール名、画像のみ入力して、設定するとサイトに表示されました。(現状この状態です)
    私の場合、その後説明に文字を入れると文字だけが表示されません。(プロフィール名、画像は表示されたままです)
    何度か検証をしてみた結果、1行分(17文字)だけ入力すると、表示されました。
    しかしながら、それ以上長い文章を入力し公開させると、すべての文章が表示されません。
    1行分しか登録できなくなってしまっているのでしょうか?

    それからプロフィール画像のリンクの件は、スラッグを「profile」にし、うまくいきました。
    ありがとうございます。

    引き続き、サイドバーのプロフィールの件、よろしくお願いいたします。


  • administrators

    @ヒーコ さん
    @jaa さん

    こんにちは!りょうたです!
    ご確認いただきありがとうございます。

    何度か検証をしてみた結果、1行分(17文字)だけ入力すると、表示されました。
    1行分しか登録できなくなってしまっているのでしょうか?

    そういう仕様ではないのであまり関係ないかと思います!
    僕の方ではテキストはどれだけ追加しても問題なく表示されているので!
    0_1584518056360_スクリーンショット 2020-03-18 16.49.48.png

    これ以上は再現性が取れないのでなんとも言えないのですが、一度他テーマに切り替えて確認してみるとどうでしょうか?
    それでもし表示が確認できる場合、JINをWordPressから削除し再度公式から最新版をダウンロードしてインストールし直してみてください。

    お手数お掛け致しますが、宜しくお願い致します。



  • @ryota さま

    ご返信ありがとうございます。

    先ほど確認しましたら、長文でも入力できました。
    よかったです。
    色々ありがとうございました。


 

});