woocomerce設定後、エラー通知が届きました。”wp-content/themes/jin/theme-update.php:108 Stack trace: #0”対処法を模索中です。ご指導いただけますと幸いです。



  • 現在の状態です。

    WordPress バーション0_1581744174554_スクリーンショット 2020-02-14 23.23.18.png 5.3.2
    現在のテーマ: JIN (バージョン 2.360)JIN-Child
    PHP バージョン7.2.27

    プラグイン
    woo commerce
    woo commerce Japan
    WooCommerce Admin

    上記3つを導入、設定後、エラー通知が届きました。
    その後、
    ダッシュボード>woocomerce>システム状況
    を確認したところ、以下の文章が表示されていました。↓

    システム状況
    Fatal error: Uncaught Error: Call to undefined function prepare_request() in /home/kotohoki8/kotohoki8.com/public_html/wp-content/themes/jin/theme-update.php:108 Stack trace: #0 /home/kotohoki8/kotohoki8.com/public_html/wp-includes/class-wp-hook.php(288): ATPU_Theme->theme_api_call(false, 'theme_informati...', Object(stdClass)) #1 /home/kotohoki8/kotohoki8.com/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(false, Array) #2 /home/kotohoki8/kotohoki8.com/public_html/wp-admin/includes/theme.php(485): apply_filters('themes_api', false, 'theme_informati...', Object(stdClass)) #3 /home/kotohoki8/kotohoki8.com/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-status.php(239): themes_api('theme_informati...', Object(stdClass)) #4 /home/kotohoki8/kotohoki8.com/public_html/wp-content/plugins/woocommerce/packages/woocommerce-rest-api/src/Controllers/Version2/class-wc-rest-system-status-v2-controller.php(1080): WC_Admin_Status::get_latest_theme_version(Object(WP_Theme)) #5 /home/kotohoki8/kotoh in /home/kotohoki8/kotohoki8.com/public_html/wp-content/themes/jin/theme-update.php on line 108
    サイトに重大なエラーがありました。 詳細については、サイト管理者のメール受信ボックスを確認してください。

    メールに届いた文章は以下の通りです。↓

    エラー詳細

    エラータイプ E_ERROR が /home/kotohoki8/kotohoki8.com/public_html/wp-content/themes/jin/theme-update.php ファイルの 108 行目で発生しました。 エラーメッセージ: Uncaught Error: Call to undefined function prepare_request() in /home/kotohoki8/kotohoki8.com/public_html/wp-content/themes/jin/theme-update.php:108
    Stack trace:
    #0 /home/kotohoki8/kotohoki8.com/public_html/wp-includes/class-wp-hook.php(288): ATPU_Theme->theme_api_call(false, 'theme_informati...', Object(stdClass))
    #1 /home/kotohoki8/kotohoki8.com/public_html/wp-includes/plugin.php(206): WP_Hook->apply_filters(false, Array)
    #2 /home/kotohoki8/kotohoki8.com/public_html/wp-admin/includes/theme.php(485): apply_filters('themes_api', false, 'theme_informati...', Object(stdClass))
    #3 /home/kotohoki8/kotohoki8.com/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-status.php(239): themes_api('theme_informati...', Object(stdClass))
    #4 /home/kotohoki8/kotohoki8.com/public_html/wp-content/plugins/woocommerce/packages/woocommerce-rest-api/src/Controllers/Version2/class-wc-rest-system-status-v2-controller.php(1080): WC_Admin_Status::get_latest_theme_version(Object(WP_Theme))
    #5 /home/kotohoki8/kotoh

    この場合、
    ・JINテーマ内のtheme-update.phpを削除すれば良いのでしょうか・・・。
    ・その他、解決方法がございましたら、ご教授いただけますと幸いです。

    また、
    もしも削除が必要だった場合なのですが、
    ・theme-update.phpの削除方法がわかりません。

    テーマエディター>functions.php
    を開くも、”theme-update.php”こちらが見つけられないでいます。涙

    phpファイルの扱い等、全く無知のため、この点もご教授いただけますと幸いです。
    素人な質問になってしまい申し訳ないのですが、
    よろしくお願いいたします。

    ちなみに、woocomerce関連のプラグインは現在「停止」にしてあります。

    Facebook for WooCommerce
    Japanized for WooCommerce
    Mailchimp for WooCommerce
    WooCommerce
    WooCommerce Admin
    WooCommerce PayPal Checkout Gateway
    WooCommerce Services
    WooCommerce Stripe ゲートウェイ

    上記8つは停止にしてありますが、他のプラグインは有効なままです。

    お忙しいことと思いますが、ご教授いただければ幸いです。
    よろしくお願いいたします。


    マニュアル確認済み
    キャッシュクリア済み
    WordPressのバージョン : 5.3.2
    ご利用のサーバー名 : エックスサーバー
    PHPのバージョン : 7.2.27
    OS :
    ご利用のブラウザ :
    該当サイトのURL : https://kotohoki8.com



  • @nine さん

    こんにちは!JIN運営チームのりょうたです。
    この度はJINご利用いただき誠にありがとうございます。

    表題の件ですが、以下トピックに同じようなものがございますのでこちらを参考にご対応いただけますと幸いでございます。

    https://jin-forum.jp/topic/519/woocommerceプラグインに関連したエラーの対処方法がわかりません/2

    上記ご確認いただき何かわからない部分がございましたら遠慮なくご連絡いただけますと幸いでございます。
    お手数お掛け致しますが、宜しくお願い致します。



  • woocomerce設定後、エラー通知が届きました。”wp-content/themes/jin/theme-update.php:108 Stack trace: #0”対処法を模索中です。ご指導いただけますと幸いです。で@nineが発言 :

    お世話になります。
    お返事ありがとうございます!

    ご提示くださったトピックを拝見させていただきました。
    同じ対処法で良い、と言うことですね。
    ありがとうございます!

    そこで、、なのですが、
    こう言ったご質問をして良いか迷うのですが、
    当方無知のため、theme-update.phpの削除方法がわかりません。

    テーマエディター>functions.php
    を開くも、”theme-update.php”こちらが見つけられないでいるのです。

    また、phpファイルを変更するにあたって、
    子テーマのみ変更でよろしいのでしょうか???

    親テーマ、子テーマの両方とも変更の必要があるでしょうか・・・。

    ご指導いただけましたら幸いです。
    お手数おかけして申し訳ございません。
    よろしくお願いいたします。



  • @nine さん

    こんにちは!りょうたです。

    テーマエディター>functions.phpを開くも、”theme-update.php”こちらが見つけられないでいるのです。

    なるほど...!!
    functions.phpの中ではなくテーマエディターのなかにtheme-update.phpっていうファイルが下あたりにあると思うのですがどうでしょうか??

    また、phpファイルを変更するにあたって、子テーマのみ変更でよろしいのでしょうか???

    基本的には親テーマのみで大丈夫だと思います!
    theme-update.phpは親テーマにしかないはずですので。。

    お手数お掛け致しますが、宜しくお願い致します。



  • りょうた様

    お忙しいところ、ご返信ありがとうございます!!
    自分にはあまりに難解でしたので、他の方にご依頼し無事解決いたしました。

    >functions.phpの中ではなくテーマエディターのなかにtheme-update.phpっていうファイルが下あたりにあると思うのですがどうでしょうか??

    はい。見当違いのところを探していたようです。涙

    >基本的には親テーマのみで大丈夫だと思います!
    theme-update.phpは親テーマにしかないはずですので。。

    そうなのですね、ありがとうございます。

    当方の勉強不足のため、お手を煩わせてしまいすみませんでした。
    また、丁寧にご指導下さいまして、ありがとうございました!

    感謝いたします。