ページ下部にWarning: count(): Parameter must be an array or an object that implements Countable in……と表示される



  • JINの公式ページ内(https://jin-theme.com/download/jin-style-demo5-download/)の下部にも、「Warning: count(): Parameter must be an array or an object that implements Countable in……public_html/wp-content/themes/jin/include/breadcrumb.php on line 199」と表示されていますが、うちのサイトも同じメッセージが表示されています。
    ただし、プラグイン「Custom Post Type UI」を利用しているページのみ、そのエラーが表示されます。

    この表示を失くすことはできないでしょうか?
    よろしくお願いいたします。


    マニュアル確認済み
    キャッシュクリア済み
    WordPressのバージョン : 5.0.3
    ご利用のサーバー名 : エックスサーバ
    PHPのバージョン : PHP7.2.6
    OS : Windows10
    ご利用のブラウザ : GoogleChrome
    該当サイトのURL : https://jin-theme.com/download/jin-style-demo5-download/



  • @kei さん

    こんばんは!JIN運営チームのりょうたです!

    お問い合わせいただいているページですが、
    通常流用されていないページになります。

    正しくは以下のページになりますのでご確認いただけますと幸いでございます。

    https://jin-theme.com/demo05-style-download/

    お手数お掛け致しますが、宜しくお願い致します。



  • 返信ありがとうございます。
    同じメッセージが私のページでも出ているという意味で、JINのページを参考として上げさせていただきました。
    この症状について、以前(2018年11月)メールで問い合わせた時は、「JINテーマ内の不具合」と返信をいただきました。
    その時はPHPのバージョンを古いバージョンで利用することで、一時的に対応できるとアドバイスをいただいています。
    しかし、その後も状況に変化がないので、ほかの利用者様でも同じことが起きたいないかと思いフォーラムに投稿した次第です。



  • @kei こんにちは!「カスタム投稿」という仕様で記事をつくると、パンくずでうまく処理できずエラーを吐いているようですね。

    こちら次回のアップデートで修正いたしますので、恐れ入りますが、もう少々お待ちいただくことは可能でしょうか?

    もし難しい場合、コードを配布して置き換えでの対応も取らせていただきます。よろしくお願い致します。



  • ひつじ様
    返信ありがとうございます。ご対応に感謝します。アップデート修正を待ちます。今後ともよろしくお願いします。